Scheduled for July 15, 2026 at 3:15 PM – 4:57 PMUTC
Affects
Virtual Private Servers
Under maintenance from 3:15 PM to 4:57 PM
Updates
Completed
July 15, 2026 at 4:57 PMUTC
Completed
July 15, 2026 at 4:57 PMUTC
Maintenance has completed successfully.
In progress
July 15, 2026 at 3:11 PMUTC
In progress
July 15, 2026 at 3:11 PMUTC
During this time we will be carrying emergency maintenance on Cloud01. We anticipate this to take around 30 minutes to an hour to complete. Do apologise for the inconvenience this that may cause.