Innova Communications - Power issue currently affecting our Reliance House facility in Newcastle. – Incident details

Power issue currently affecting our Reliance House facility in Newcastle.

Resolved
Degraded performance
Started 4 months agoLasted about 7 hours

Affected

Reliance House, Newcastle Datacentre

Degraded performance from 1:42 AM to 8:58 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. No downtime has occurred during this or the monitoring period.

  • Update
    Update

    We had an electrical fault impacting some cooling circuits within the data centre facility. Our engineering team implemented remedial works to stabilise power and are monitoring closely.

  • Monitoring
    Monitoring

    We have implemented a fix for the earlier power issue and our systems are now stable. Our engineers remain on-site and are actively monitoring to ensure full service continuity.

  • Identified
    Identified

    We are aware of a power issue currently affecting our Reliance House facility in Newcastle. Our engineers are on-site and working to restore full service as quickly as possible.

    Please note that all critical systems are provisioned with dual power feeds, which should ensure continued operation for the majority of customers.